[Logo] Форум ПАРУС
Настройка сервиса ЭЛН  XML
Индекс форума » 8.хх Зарплата и Кадры
Автор Сообщение
FOX
Пользователь

Зарегистрирован: 06.11.2012 13:58:55
Сообщений: 201
Оффлайн

А если дело в интернете через прокси, то сервису нашему просто надо этот прокси-сервер указать.
SERGVM
Новичок

Зарегистрирован: 24.12.2015 11:37:33
Сообщений: 15
Оффлайн

Прописали в bindings.config в раздел адрес прокси:
<binding name="AisElnEncryptedHttpBinding" proxyAddress="http://proxy.uts.vpn:3128" useDefaultWebProxy="false">
<security mode="Transport" />
</binding>

Заработало!
BSI
Пользователь

Зарегистрирован: 13.11.2012 12:25:42
Сообщений: 214
Оффлайн

Может кто нибудь сбросить файл ЭЛН? Сейчас веду неконструктивный диалог с заказчиком на тему"файл правильный, это ваш парус .авно". Нужно визуально показать, что формат неверный.
bsi_07{собака}bk.ru
ESINA
Пользователь

Зарегистрирован: 08.11.2017 17:53:51
Сообщений: 266
Оффлайн

Документ "Спецификация_ЭЛН_Страхователь_v_1_1_20180316.doc"
Пункт "6.1.3. Пример запроса"
Поиск по "GETLNINS".

https://cabinets.fss.ru/Спецификация_ЭЛН_Страхователь_v_1_1_20180316.doc
 Имя файла GETLNINS_3103275205_2017_07_11_00116.xml [Disk] Скачать
 Описание Описание отсутствует
 Размер файла 10 Kbytes
 Загружено:  4 раз(а)

GENNADY80
Новичок

Зарегистрирован: 20.10.2014 18:23:31
Сообщений: 28
От:
Оффлайн

Как узнать куда ушел реестр по ЭЛН? В Парус загрузил ЭЛН отработал, создал реестр, отправил его через журнал взаимодействия ФСС, результат Парус написал "Реестр успешно загружен". Но звоним в ФСС они его не видят, смотрим на шлюз ФСС http://docs.fss.ru/home/upinfo там его тоже нет.
[Email]
GENNADY80
Новичок

Зарегистрирован: 20.10.2014 18:23:31
Сообщений: 28
От:
Оффлайн

При повторной отправке этого реестра уже выдается ошибка: ORA-20013: Не удалось обновить данные. Обновляемая запись потеряла актуальность. То есть получается, что он все таки куда то загрузился?
[Email]
DEN
Новичок

Зарегистрирован: 08.11.2012 17:13:21
Сообщений: 159
Оффлайн

Этот ответ был сгенерирован сервисом самого ФСС, т.е. данные до них дошли.
RMSUFA
Новичок

Зарегистрирован: 09.10.2012 21:41:50
Сообщений: 52
Оффлайн

в сентябре работало, а сейчас получаю ошибку:
Ошибка сервиса: "Дескриптор имеет неправильное состояние для запрошенного действия - URL:http://localhost/serviceproxy/AisElnService.svc - SOAPAction:http://schemas.parus.ru/v8/services/proxy/aiseln/IAisElnService/GetElnDataGetHashes".
куда копать?
[Email]
YUYA
Новичок

Зарегистрирован: 14.01.2013 17:40:16
Сообщений: 23
Оффлайн

У меня такая же выскакивает. Вы как-то с ней справились?
YUYA
Новичок

Зарегистрирован: 14.01.2013 17:40:16
Сообщений: 23
Оффлайн

Справились - настроили dblinks.config
YUYA
Новичок

Зарегистрирован: 14.01.2013 17:40:16
Сообщений: 23
Оффлайн

Теперь другая песня - Ошибка сервиса: "Устройство не готово.".
Ключи все установлены. Но чего то не хватает (((
DEN
Новичок

Зарегистрирован: 08.11.2012 17:13:21
Сообщений: 159
Оффлайн

YUYA wrote:Теперь другая песня - Ошибка сервиса: "Устройство не готово.".
Ключи все установлены. Но чего то не хватает (((


У вас версия Парус-8 и веб сервера совпадают?
ALEXK
Новичок

Зарегистрирован: 16.03.2016 16:57:10
Сообщений: 9
Оффлайн

SERGVM wrote:Прописали в bindings.config в раздел адрес прокси:
<binding name="AisElnEncryptedHttpBinding" proxyAddress="http://proxy.uts.vpn:3128" useDefaultWebProxy="false">
<security mode="Transport" />
</binding>

Заработало!


Добрый день!
А не подскажите как тут можно имя пользователя и пароль прописать?
Прокси работает только с указанием пользователя и пароля.
SERGVM
Новичок

Зарегистрирован: 24.12.2015 11:37:33
Сообщений: 15
Оффлайн

Настраивали по ссылке:

http://codehelper.ru/questions/210/new/%D1%80%D0%B0%D0%B1%D0%BE%D1%82%D0%B0-wcf-%D0%BA%D0%BB%D0%B8%D0%B5%D0%BD%D1%82%D0%B0-%D1%87%D0%B5%D1%80%D0%B5%D0%B7-web-proxy

Правда, про пароли и явки в явном виде, ничего не было...
GENNADY80
Новичок

Зарегистрирован: 20.10.2014 18:23:31
Сообщений: 28
От:
Оффлайн

А у нас такая ошибка: Ошибка сервиса: "Адресат вызова создал исключение.". Никто не знает как ее решить?
[Email]
DEN
Новичок

Зарегистрирован: 08.11.2012 17:13:21
Сообщений: 159
Оффлайн

Скорее всего проблемы с CryptoPro Net. У вас лицензия не закончилась?
GENNADY80
Новичок

Зарегистрирован: 20.10.2014 18:23:31
Сообщений: 28
От:
Оффлайн

Подскажите, что означает ошибка на машине клиента, при попытке загрузить ЭЛН и после выбора подписи выдает такое "Сеанс не начат" какой сеанс не начат?
[Email]
BSI
Пользователь

Зарегистрирован: 13.11.2012 12:25:42
Сообщений: 214
Оффлайн

А я вот такую фигню получа. Это изза чего?
[Thumb - элн.jpg]
 Имя файла элн.jpg [Disk] Скачать
 Описание Описание отсутствует
 Размер файла 41 Kbytes
 Загружено:  5 раз(а)

FOX
Пользователь

Зарегистрирован: 06.11.2012 13:58:55
Сообщений: 201
Оффлайн

Обновите КриптоПро.NET
MINZDRAVRF
Новичок

Зарегистрирован: 07.11.2012 12:55:44
Сообщений: 8
Оффлайн

Добрый день. Сталкивался кто-нибудь с такой ошибкой?: Пытаюсь получить данные ЭЛН


Ошибка сервиса: "ExecutionContext.UserName cant by empty for specified connection mode.
Имя параметра: executionContext".

Релиз 25 декабря 2018
Логов парус при этом не пишет.

Сертификаты все стоят, отпечатки прописаны, права на реестр даны. Может я какие-то реквизиты организации не указал? Что нужно заполнить в реквизитах работодателя для работы с ЭЛН: ОГРН. рег номер ФСС, код подчиненности в фсс?
[Email]
FOX
Пользователь

Зарегистрирован: 06.11.2012 13:58:55
Сообщений: 201
Оффлайн

Версии ВИН и ВЕБ не совпадают
MINZDRAVRF
Новичок

Зарегистрирован: 07.11.2012 12:55:44
Сообщений: 8
Оффлайн

Спасибо, действительно, версии были из разных релизов. перед настройкой я обновил релиз на февраль 2019, а приложение proxy осталось от 25.12.2018

Обновил каталог proxy до февраля 2019.
В февральском 2019 релизе в приложении proxy появился конфиг secure.config,
<?xml version="1.0"?>
<security>
<!-- mode = Net | CryptoPro -->
<crypto legacy="True" mode="Net"/>
</security>

Конфиг не описан на сегодня в инструкциях по настройке web/Proxy (ни в одной из имеющихся), как не описан и в сопроводительной записке к релизу.
у меня возникала ошибка при попытке получить ЭЛН: Инициализатор типа "CryptoApiNetNative.Native.SignedXmlRelated.Xml.SignedXmlEx" выдал исключение.

Поправил строку <crypto legacy="false" mode="Net"/> на <crypto legacy="false" mode="CryptoPro"/> . Заработало
[Email]
SERGVM
Новичок

Зарегистрирован: 24.12.2015 11:37:33
Сообщений: 15
Оффлайн

Последнее время начала появляться ошибка:

Ошибка сервиса: "Provider DLL failed to initialize correctly.".

Сертификаты рабочие, КриптоПро с НЕТ тоже. Никто не сталкивался?
SERGVM
Новичок

Зарегистрирован: 24.12.2015 11:37:33
Сообщений: 15
Оффлайн

Перегрузили WEB-сервер,- ошибка ушла, но ... Где гарантия, что не возникнет опять?
YUSLA
Новичок

Зарегистрирован: 06.11.2012 09:38:26
Сообщений: 29
От: Вячеслав Юдин
Оффлайн

У нас такая же ошибка возникала каждый день последние две недели, перезагрузка веб-сервера помогала ненадолго.
Вчера поставил КриптоПро, последний релиз, наблюдаю, пока непонятно помогло или нет.
[Email]
YUSLA
Новичок

Зарегистрирован: 06.11.2012 09:38:26
Сообщений: 29
От: Вячеслав Юдин
Оффлайн

да, после переустановки КриптоПро эта ошибка больше не появлялась
[Email]
ALEXK
Новичок

Зарегистрирован: 16.03.2016 16:57:10
Сообщений: 9
Оффлайн

Добрый день!
Не подскажете, что за сообщение об ошибке: Устройство не готово.
Появилось после обновления на апрель 19. Версия Паруса и ВЭБ совпадает.
Лицензия на КриптоПро не закончилась.
Не могу понять какое устройство не готово.
FOX
Пользователь

Зарегистрирован: 06.11.2012 13:58:55
Сообщений: 201
Оффлайн

Проверяйте в настройках пути к временным файлам и логам
TORNADO
Новичок

Зарегистрирован: 09.04.2014 11:36:04
Сообщений: 60
Оффлайн

При отправке реестра пособий с количеством людей >10(примерно), выдает ошибку Ошибка сервиса: "Request Entity Too Large (413) - 'http://10.11.2.203:8080/ServiceProxy/AisElnService.svc'". Что делать? Все, что предлагал гугл(поменять maxReceivedMessageSize, и прописать readerQuotas, изменить uploadreadaheadsize) результата не принес...
SERGVM
Новичок

Зарегистрирован: 24.12.2015 11:37:33
Сообщений: 15
Оффлайн

To Den:

Обновились на февральский релиз. Заменили папку serviceproxy, заново настроили конфигурационные файлы (один из них кстати сильно изменился). При попытке получить ЭЛН выходит ошибка
Ошибка сервиса: "Устройство не готово.
".
Что может быть?

Обновились на июнь 2019, и уперлись в эту же ошибку - не разобрались? Уж очень не хочется все по шагам "проползать"...
 
Индекс форума » 8.хх Зарплата и Кадры
Перейти: